View Single Post
Old 06/15/2017, 08:35 AM   #2918
slief
RC Sponsor

 
slief's Avatar
 
Join Date: Sep 2009
Location: Simi Valley, Ca
Posts: 13,341
Quote:
Originally Posted by ngdv View Post
I have recently purchased a bubble King mini 160 vs12. Put it in de sump, start it up and for some reason I can't get a proper skim from it. It feels like it's getting to much air or to less water. The skim won't go past halve the lower part, not even close to the collection cup. I'm having it in a red sea reefer 250, around 20cm(8") water height . Yet it won't skim. Did any of you have this problems in the start of the new skimmer?

Foto shows what I mean.
Close the wedge pipe some to get the water level up to about 1" below the white PVC collar at the top of the body. Also, you may want to loose the set screw that keeps the wedge pipe tight and make sure the wedge pipe is seated all the way down into the effluent fitting. If it's not all the way seated, the wedge pipe will not function and you won't be able to raise the level in the skimmer.

How long has the skimmer been in the sump? I assume you have it in salt water and not fresh water for testing?


__________________
Director Customer Support Royal Exclusiv USA
For All Royal Exclusiv & Bubble King questions please refer to our Sponsor forum: http://www.reefcentral.com/forums/fo...play.php?f=745

Current Tank Info: 480G display mixed reef, 90G sump, 90G refugium, 60G display refugium. Check out my build thread: http://www.reefcentral.com/forums/showthread.php?t=1783476
slief is online now   Reply With Quote