Reef Central Online Community
Blue Zoo Aquatics

Home Forum Here you can view your subscribed threads, work with private messages and edit your profile and preferences View New Posts View Today's Posts

Find other members Frequently Asked Questions Search Reefkeeping ...an online magazine for marine aquarists Support our sponsors and mention Reef Central

Go Back   Reef Central Online Community > Sponsor Forums > Neptune Systems
Register Blogs FAQ Calendar Mark Forums Read

Notices

Reply
Thread Tools
Old 09/18/2017, 10:01 AM   #1
PAXpress
Registered Member
 
Join Date: Nov 2015
Posts: 326
Apex programming question and check my code.

I'm going to post this here because doesn't seem like people posting on the Apex forum are getting answered very quickly...

Check my code on my heaters.

What I want is the heater to be off for 15 minutes when feeda is activated and also turn off for 35 minutes when feedb is activated. And of course to do the normal, on when temp hits 77.9 and off when it hits 79.1 Does this look right? And also to prevent probe issue from causing it to stick on then lower than 73 its off. Let me know if I did something silly here?



Fallback OFF
If DisTmp < 78.0 Then ON
If DisTmp > 79.0 Then OFF
If DisTmp < 73.0 Then OFF
If FeedA 015 then off
If feedB 035 then off


And my second heater's prog looks like this. Idea is similar for this heater but for if the other heater isn't able to maintain the temp or temp drops too low this is the backup. I live in a cold env and want to have a secondary heater to takeover if the first cant keep up.

Fallback OFF
If DisTmp < 76.5 Then ON
If DisTmp > 78.0 Then OFF
If DisTmp < 72.0 Then OFF
If FeedA 015 then off
If FeedB 035 then off


And then my second question...

Havent done much with the timing statements. I have a gyre and want to set a specific time every day that it is off for 15 minutes... I'm sure this is pretty simple but I'd rather not screw it up. Thanks in advance!
I'd assume it'd be something like this...

Fallback On
Set On
If time 22:00 then off
If time 22:15 then on

Or is this totally wrong?


__________________
Visit my youtube channel to see my tanks! https://www.youtube.com/channel/UCSR-zK-vmMShByAFT5hBRmA
PAXpress is offline   Reply With Quote
Old 09/18/2017, 10:27 PM   #2
kurt_n
Registered Member
 
Join Date: May 2006
Location: WA
Posts: 2,540
Your heater code looks OK. With the Feed cycle programming, just be aware that you're asking for the heaters to be off for however long your feed cycle is set for *plus* the delay time you've noted. In other words, if FeedA is set for 5 minutes, the heater will be off for a total of 20 minutes after you hit the FeedA button.

As far as your programming for the gyre, you can just do this:

Fallback On
Set On
If Time 22:00 to 22:15 Then OFF


kurt_n is offline   Reply With Quote
Old 09/20/2017, 02:45 PM   #3
PAXpress
Registered Member
 
Join Date: Nov 2015
Posts: 326
Quote:
Originally Posted by kurt_n View Post
Your heater code looks OK. With the Feed cycle programming, just be aware that you're asking for the heaters to be off for however long your feed cycle is set for *plus* the delay time you've noted. In other words, if FeedA is set for 5 minutes, the heater will be off for a total of 20 minutes after you hit the FeedA button.

As far as your programming for the gyre, you can just do this:

Fallback On
Set On
If Time 22:00 to 22:15 Then OFF
Perfect and yes that is what I want for the feed cycle. I have the return off during this time and it will probably melt something or destroy the heater if it stays on. The idea is to turn off all flow to feed corals for that cycle and the other is for maint (pump cleaning water change etc)
Awesome I'll add that in for my gyre. thanks!


__________________
Visit my youtube channel to see my tanks! https://www.youtube.com/channel/UCSR-zK-vmMShByAFT5hBRmA
PAXpress is offline   Reply With Quote
Old 09/21/2017, 10:39 AM   #4
mjc0760
Registered Member
 
mjc0760's Avatar
 
Join Date: Feb 2015
Location: Robbinsville NJ
Posts: 57
I'm curious about the purpose of having the gyre off at the same time every day? Are you coordinating it with an auto feeder or something for that same time slot?


__________________
Aqueon 90g RR, Trigger Systems Emerald 34 sump, 2 Radion XR30w G3 PROs, Vertex Omega 150 Skimmer, MaxSpect Gyre XF130 and XF230, Sicce Syncra Silent 4.0 Return, Apex Controller, Avast ATO, BRS Media R

Current Tank Info: 90 gallon mixed reef
mjc0760 is offline   Reply With Quote
Old 09/21/2017, 11:57 AM   #5
PAXpress
Registered Member
 
Join Date: Nov 2015
Posts: 326
Quote:
Originally Posted by mjc0760 View Post
I'm curious about the purpose of having the gyre off at the same time every day? Are you coordinating it with an auto feeder or something for that same time slot?
So I have one of the new Red Sea Peninsula tanks. I have a 1800ish gph return pump and then the gyre is positioned on the same side as the return and the overflow. I'll attach a picture to make things a bit easier to visualize. As you can see in the picture (hopefully) on the right side is the overflow gyre and return nozzle. My issue could be related to the amount of dust in my house with the open top... crud in the water, sediment from adding the sand or something but I seem to constantly have this "film" and proteins or something on the surface of the water. I have the gyre aimed at the surface and its about 6 or so inches from the water surface. What ends up happening is the gyre pushes the surface water to the far end of the tank then the water comes back around in a gyre type of circular flow. However the lighter particles and whatever film is there seems to stay at the surface at the far end. I can see it when I look from below the right side has that very clear rippled water and the left side has the scuzzy filmy crap on the surface. This also leads to a white gunk all around the edges of the tank from where it gets stuck on the glass and dries just above the waterlevel.
My hypothesis is that the gyre cutting off for 15 minutes (twice a day) will allow for the return to continue running, flow will be reduced for a short time but not actually that much because I run the gyre at max 20% so it goes 10-20% all day, and the return which is pointed down just slightly will allow for the surface to be skimmed and that film to be processed by the filter socks skimmer and fuge.

TLDR peninsula tank pushes surface film to far end and never gets surface skimmed.


Attached Images
File Type: jpg IMG_4814.jpg (46.8 KB, 11 views)
__________________
Visit my youtube channel to see my tanks! https://www.youtube.com/channel/UCSR-zK-vmMShByAFT5hBRmA
PAXpress is offline   Reply With Quote
Old 09/21/2017, 11:58 AM   #6
PAXpress
Registered Member
 
Join Date: Nov 2015
Posts: 326
And actually I just now noticed in the picture you can see the surface scuzz in that picture fairly well actually.


__________________
Visit my youtube channel to see my tanks! https://www.youtube.com/channel/UCSR-zK-vmMShByAFT5hBRmA
PAXpress is offline   Reply With Quote
Old 09/21/2017, 03:30 PM   #7
mjc0760
Registered Member
 
mjc0760's Avatar
 
Join Date: Feb 2015
Location: Robbinsville NJ
Posts: 57
Have you tried the Gyre closer to the surface? You should get better movement across the surface (laminar flow) and break up the film without the gyre sucking in air. I have mine only about 3" from the surface of the water and aimed straight across the tank. (Pic attached)


Attached Images
File Type: jpg Gyre pic.jpg (52.6 KB, 2 views)
__________________
Aqueon 90g RR, Trigger Systems Emerald 34 sump, 2 Radion XR30w G3 PROs, Vertex Omega 150 Skimmer, MaxSpect Gyre XF130 and XF230, Sicce Syncra Silent 4.0 Return, Apex Controller, Avast ATO, BRS Media R

Current Tank Info: 90 gallon mixed reef
mjc0760 is offline   Reply With Quote
Old 09/25/2017, 10:39 AM   #8
PAXpress
Registered Member
 
Join Date: Nov 2015
Posts: 326
Quote:
Originally Posted by mjc0760 View Post
Have you tried the Gyre closer to the surface? You should get better movement across the surface (laminar flow) and break up the film without the gyre sucking in air. I have mine only about 3" from the surface of the water and aimed straight across the tank. (Pic attached)
I did actually I started it higher probably 2-3" from the surface and due to the outflow of the return pump, was seeing vortexes and bubbles getting sucked into the gyre. I was seeing pretty frequent vortexes near the pump and on the far end of the tank was seeing vortexes that would suck a bubble all the way from the surface to nearly the sand bed of the tank and twirl it around back and forth for a while until it got pushed elsewhere. I had to lower the gyre almost 5-6 inches to get this affect to stop.


__________________
Visit my youtube channel to see my tanks! https://www.youtube.com/channel/UCSR-zK-vmMShByAFT5hBRmA
PAXpress is offline   Reply With Quote
Old 09/25/2017, 10:43 AM   #9
PAXpress
Registered Member
 
Join Date: Nov 2015
Posts: 326
However I will note that I'm seeing the scuz on the surface begin to fade. Have it set to give two off times at "sun" up and "sun" down and there is almost no surface scuz left. Perhaps after a while of doing this I can remove this from my programming and it may not come back. Think a lot of it is caused by the sand when it was added was very dusty. I have mainly LPS that honestly seem irritated by the constant flow of the gyre even with it set to 20% max (goes from 10-20 all day). Only have a few that want the higher flow anyways and I'm sure they will be just fine for the 15 minutes of no flow.


__________________
Visit my youtube channel to see my tanks! https://www.youtube.com/channel/UCSR-zK-vmMShByAFT5hBRmA
PAXpress is offline   Reply With Quote
Old 09/26/2017, 07:37 AM   #10
five.five-six
Registered Member
 
five.five-six's Avatar
 
Join Date: Mar 2007
Location: Corona
Posts: 5,116
Quote:
Originally Posted by PAXpress View Post
And actually I just now noticed in the picture you can see the surface scuzz in that picture fairly well actually.
Yea, that's not good.


__________________
Originally posted by yellowslayer13:

"I hate that hole"

Current Tank Info: SCMAS Member 135 peninsula euroreef RS180 Apex 250W X2 20k radiums mixed SPS
five.five-six is online now   Reply With Quote
Old 09/26/2017, 01:30 PM   #11
PAXpress
Registered Member
 
Join Date: Nov 2015
Posts: 326
Quote:
Originally Posted by five.five-six View Post
Yea, that's not good.
Think its mostly gone now. I'll have to get an updated picture.


__________________
Visit my youtube channel to see my tanks! https://www.youtube.com/channel/UCSR-zK-vmMShByAFT5hBRmA
PAXpress is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -6. The time now is 11:13 PM.


TapaTalk Enabled

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Use of this web site is subject to the terms and conditions described in the user agreement.
Reef CentralTM Reef Central, LLC. Copyright 1999-2014