Reef Central Online Community
Marine Depot

Home Forum Here you can view your subscribed threads, work with private messages and edit your profile and preferences View New Posts View Today's Posts

Find other members Frequently Asked Questions Search Reefkeeping ...an online magazine for marine aquarists Support our sponsors and mention Reef Central

Go Back   Reef Central Online Community > Sponsor Forums > Royal Exclusiv / Bubble King
Register Blogs FAQ Calendar Mark Forums Read

Notices

User Tag List

Reply
Thread Tools
Old 03/22/2019, 10:50 AM   #1
jmm
Registered Member
 
jmm's Avatar
 
Join Date: Jan 2015
Location: Dallas, TX
Posts: 569
BK mini 180 pump problems

I have a BK mini 180 skimmer that is about 3 1/2 years old. The pump motor has stopped working. I have disassembled the pump and removed the impeller. Everything is clean. With the pump out and exposed, I can plug it in and it turns the impeller for a couple of turns with a motor noise and then it freezes up and the motor noise goes away. I can finger start it but it will only turn a couple of times and then stop. It almost seems like it would like to go backwards. The impeller can be turned with the power off with some difficulty. The magnet is not loose on the shaft. Is this repairable or do I need a new $$$$pump?


jmm is offline   Reply With Quote
Old 03/22/2019, 01:57 PM   #2
slief
RC Sponsor

 
slief's Avatar
 
Join Date: Sep 2009
Location: Simi Valley, Ca
Posts: 13,819
Clearly you’ve done your reading and answered pretty much any questions I would have thrown at you in terms of troubleshooting.

You definitely don’t need a whole new pump. If the bearing at the bottom of the magnet cavity is clean and calcium free and there is no buildup on the bottom of the impeller shaft below the magnet then it sounds like you just need a new motor block. If your pump has the AKB (red tube that goes from the pressure side (front of the pump) to the rear side of the pump, then this is the replacement block you need. This fits the Mini Bubble King 180’s from 2012 onward that had the AKB.
https://royalexclusiv.com/Spare-Part...bdb3159f464324

It wouldn’t hurt to put the motor and impeller in some straight distilled vinegar for 10 minutes and then take a tooth brush to the inside of the block and a dish brush to the impeller just to rule out any calcification. In the future, if you break the pump down and clean it inside and out with a 10 minute vinegar soak and a good scrubbing inside and out followed by a rinse, those pumps will typically last many many years. The key is preventing calcium buildup inside the motor and lower bearing area and also keeping things out of the pumps intake as either scenario can result in premature failure.


__________________
Director Customer Support Royal Exclusiv USA
For All Royal Exclusiv & Bubble King questions please refer to our Sponsor forum: http://www.reefcentral.com/forums/fo...play.php?f=745

Current Tank Info: 480G display mixed reef, 90G sump, 90G refugium, 60G display refugium. Check out my build thread: http://www.reefcentral.com/forums/showthread.php?t=1783476
slief is online now   Reply With Quote
Old 03/22/2019, 03:52 PM   #3
jmm
Registered Member
 
jmm's Avatar
 
Join Date: Jan 2015
Location: Dallas, TX
Posts: 569
Thanks for your prompt reply. I tried the link you provided and saw the motor block. However, when I tried to buy it (put it in the cart) it said I had nothing in the cart. I filled out the new customer form and it wouldn't accept that either. When I pressed continue, it just erased the application and when I filled it out again and pressed continue, the same thing happened. Any suggestions? I use Safari on a Mac computer.


jmm is offline   Reply With Quote
Old 03/22/2019, 04:04 PM   #4
slief
RC Sponsor

 
slief's Avatar
 
Join Date: Sep 2009
Location: Simi Valley, Ca
Posts: 13,819
Quote:
Originally Posted by jmm View Post
Thanks for your prompt reply. I tried the link you provided and saw the motor block. However, when I tried to buy it (put it in the cart) it said I had nothing in the cart. I filled out the new customer form and it wouldn't accept that either. When I pressed continue, it just erased the application and when I filled it out again and pressed continue, the same thing happened. Any suggestions? I use Safari on a Mac computer.
The website doesn’t like certain browser versions and that is exactly what happens with the browser issue. I know Germany is working on fixing that. Try a different browser such as Chrome and it should work.


__________________
Director Customer Support Royal Exclusiv USA
For All Royal Exclusiv & Bubble King questions please refer to our Sponsor forum: http://www.reefcentral.com/forums/fo...play.php?f=745

Current Tank Info: 480G display mixed reef, 90G sump, 90G refugium, 60G display refugium. Check out my build thread: http://www.reefcentral.com/forums/showthread.php?t=1783476
slief is online now   Reply With Quote
Old 03/23/2019, 10:15 AM   #5
jmm
Registered Member
 
jmm's Avatar
 
Join Date: Jan 2015
Location: Dallas, TX
Posts: 569
Quote:
Originally Posted by slief View Post
The website doesn’t like certain browser versions and that is exactly what happens with the browser issue. I know Germany is working on fixing that. Try a different browser such as Chrome and it should work.
Chrome worked. I got it ordered but it said it was out of stock. Any idea how soon that order will be fulfilled?


jmm is offline   Reply With Quote
Old 03/23/2019, 02:56 PM   #6
slief
RC Sponsor

 
slief's Avatar
 
Join Date: Sep 2009
Location: Simi Valley, Ca
Posts: 13,819
Quote:
Originally Posted by jmm View Post
Chrome worked. I got it ordered but it said it was out of stock. Any idea how soon that order will be fulfilled?
Not sure but I think we might actually have them. I am double checking with Ft. Myers and Germany to see what the status of them is. I will likely PM you Monday.


__________________
Director Customer Support Royal Exclusiv USA
For All Royal Exclusiv & Bubble King questions please refer to our Sponsor forum: http://www.reefcentral.com/forums/fo...play.php?f=745

Current Tank Info: 480G display mixed reef, 90G sump, 90G refugium, 60G display refugium. Check out my build thread: http://www.reefcentral.com/forums/showthread.php?t=1783476
slief is online now   Reply With Quote
Old 04/25/2019, 12:29 AM   #7
chowder
Registered Member
 
Join Date: Dec 2007
Posts: 20
I received a newsletter advertising the availability of a retrofit kit for the mini 180 using the new red dragon 6 dc pump. That might be an option for you as well.


Sent from my iPhone using Tapatalk


chowder is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 03:53 PM.


TapaTalk Enabled

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Use of this web site is subject to the terms and conditions described in the user agreement.
Reef CentralTM Reef Central, LLC. Copyright ©1999-2014
User Alert System provided by Advanced User Tagging v3.3.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.