Reef Central Online Community

Home Forum Here you can view your subscribed threads, work with private messages and edit your profile and preferences View New Posts View Today's Posts

Find other members Frequently Asked Questions Search Reefkeeping ...an online magazine for marine aquarists Support our sponsors and mention Reef Central

Go Back   Reef Central Online Community > Sponsor Forums > Bulk Reef Supply
Register Blogs FAQ Calendar Mark Forums Read

Notices

 
Thread Tools
Old 04/05/2017, 04:15 PM   #1
moe103
Registered Member
 
Join Date: May 2006
Location: New Jersey
Posts: 73
Dual Reactor fittings leaking

I recently purchased the dual reactor and set it up. The fittings of the ball valve and the in elbow are leaking. How do I fix this?

Thank you


moe103 is offline  
Old 04/06/2017, 10:04 AM   #2
Randy_BRS
Registered Member
 
Randy_BRS's Avatar
 
Join Date: Feb 2017
Posts: 174
Oh no! That's no good at all! We can definitely get you taken care of, whether through troubleshooting the fittings or sending you replacements. Not to worry at all!

First we'll want to do some quick troubleshooting to see if a quick fix solves the issue. Often, more times than not, if you pull the tubing out of the push connect fittings; check the tubing for a clean cut that isn't crooked; re-cut if you have to; then re-insert into the fitting as far as it will go; that usually does the trick!

If that doesn't work for you, we will make it right immediately! Please try out that remedy and if it is still leaking, give our CS team a quick call at 763-432-9691 and they will have you set in no time. (If you mention that you already tried these troubleshooting steps, they can jump straight to the next solution.)

Please, don't hesitate to reach out to me here if you need any further help or have any other questions!

-Randy


Randy_BRS is offline  
Old 04/20/2017, 10:43 PM   #3
moe103
Registered Member
 
Join Date: May 2006
Location: New Jersey
Posts: 73
Thanks for your quick response Randy. I trimmed the edges, re-inserted and its working perfectly without leaks.


moe103 is offline  
Old 04/21/2017, 11:57 AM   #4
Randy_BRS
Registered Member
 
Randy_BRS's Avatar
 
Join Date: Feb 2017
Posts: 174
Quote:
Originally Posted by moe103 View Post
Thanks for your quick response Randy. I trimmed the edges, re-inserted and its working perfectly without leaks.
Great news! I'm so glad it's working for you now!

Happy Reefing!

-Randy


Randy_BRS is offline  
Old 05/16/2017, 11:07 PM   #5
shakaloha
Registered Member
 
Join Date: May 2017
Posts: 18
I had the same issue and they fixed it fast! One just wasn't set and the other had a bad o-ring, they sent me a new fitting asap. BRS is great


shakaloha is offline  
Old 05/17/2017, 08:10 AM   #6
Randy_BRS
Registered Member
 
Randy_BRS's Avatar
 
Join Date: Feb 2017
Posts: 174
Quote:
Originally Posted by shakaloha View Post
I had the same issue and they fixed it fast! One just wasn't set and the other had a bad o-ring, they sent me a new fitting asap. BRS is great
Thanks!


Randy_BRS is offline  
 

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -6. The time now is 04:44 PM.


TapaTalk Enabled

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Use of this web site is subject to the terms and conditions described in the user agreement.
Reef CentralTM Reef Central, LLC. Copyright 1999-2014