Reef Central Online Community
Marine Depot

Home Forum Here you can view your subscribed threads, work with private messages and edit your profile and preferences View New Posts View Today's Posts

Find other members Frequently Asked Questions Search Reefkeeping ...an online magazine for marine aquarists Support our sponsors and mention Reef Central

Go Back   Reef Central Online Community > Sponsor Forums > Royal Exclusiv / Bubble King
Register Blogs FAQ Calendar Mark Forums Read

Notices

User Tag List

Reply
Thread Tools
Old 02/17/2021, 01:02 PM   #1
tpallas
Registered Member
 
tpallas's Avatar
 
Join Date: Feb 2007
Location: Arlington, VA
Posts: 439
Tear in Pump Cord

I have an older style Mini 160. I've been having issues with the pump and discovered this today. Do I need to replace the entire pump block?


Attached Images
File Type: jpg Skimmer.jpg (61.6 KB, 12 views)
tpallas is offline   Reply With Quote
Old 02/20/2021, 07:53 PM   #2
slief
RC Sponsor

 
slief's Avatar
 
Join Date: Sep 2009
Posts: 14,131
Quote:
Originally Posted by tpallas View Post
I have an older style Mini 160. I've been having issues with the pump and discovered this today. Do I need to replace the entire pump block?
Not sure why I didnít get a notification for your post. Sorry for the late reply. A new motor would be the best bet but you can try liquid electrical tape. Just clean the cord well before applying it.


__________________
Director Customer Support Royal Exclusiv USA
For All Royal Exclusiv & Bubble King questions please refer to our Sponsor forum: http://www.reefcentral.com/forums/fo...play.php?f=745

Current Tank Info: 480G display mixed reef, 90G sump, 90G refugium, 60G display refugium. Check out my build thread: http://www.reefcentral.com/forums/showthread.php?t=1783476
slief is offline   Reply With Quote
Old 02/20/2021, 07:58 PM   #3
slief
RC Sponsor

 
slief's Avatar
 
Join Date: Sep 2009
Posts: 14,131
This is the replacement block should you decide to replace the motor.
https://royalexclusiv.com/Spare-Part...bfa11945869048


__________________
Director Customer Support Royal Exclusiv USA
For All Royal Exclusiv & Bubble King questions please refer to our Sponsor forum: http://www.reefcentral.com/forums/fo...play.php?f=745

Current Tank Info: 480G display mixed reef, 90G sump, 90G refugium, 60G display refugium. Check out my build thread: http://www.reefcentral.com/forums/showthread.php?t=1783476
slief is offline   Reply With Quote
Old 02/24/2021, 07:12 AM   #4
tpallas
Registered Member
 
tpallas's Avatar
 
Join Date: Feb 2007
Location: Arlington, VA
Posts: 439
Thank you. I accidentally ordered the pump version without the AKB. Is that a problem? When I installed it, the pump is making an audible humming noise, it clearly isn't working correctly. I tried just the pump (no air), and it is still making the noise. Any ideas


tpallas is offline   Reply With Quote
Old 02/25/2021, 08:23 AM   #5
slief
RC Sponsor

 
slief's Avatar
 
Join Date: Sep 2009
Posts: 14,131
Quote:
Originally Posted by tpallas View Post
Thank you. I accidentally ordered the pump version without the AKB. Is that a problem? When I installed it, the pump is making an audible humming noise, it clearly isn't working correctly. I tried just the pump (no air), and it is still making the noise. Any ideas
I think we communicated yesterday or the day before. Capping off the AKB port on the pumps output would be the thing I’d do first. Soaking the impeller and pump cover in undiluted vinegar and scrubbing them well would be next. The hum is either from water exiting the AKB port on the pumps output or possibly from the impellers bearing having some buildup in it. Thus cleaning it should help. Also double check that the bearing in the inside of the motor block is properly seated inside the motorblock before the impeller goes in.


__________________
Director Customer Support Royal Exclusiv USA
For All Royal Exclusiv & Bubble King questions please refer to our Sponsor forum: http://www.reefcentral.com/forums/fo...play.php?f=745

Current Tank Info: 480G display mixed reef, 90G sump, 90G refugium, 60G display refugium. Check out my build thread: http://www.reefcentral.com/forums/showthread.php?t=1783476
slief is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 03:34 PM.


TapaTalk Enabled

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2021 Axivo Inc.
Use of this web site is subject to the terms and conditions described in the user agreement.
Reef CentralTM Reef Central, LLC. Copyright ©1999-2014
User Alert System provided by Advanced User Tagging v3.3.0 (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.